Nicht alle communities von lemmy.ml verfügbar?

Hallo, ich bin gerade dabei von Lases^WReddit auf Lemmy umzusteigen. Kann es sein, dass nur “aktivere” Communities via 161.social erreichbar sind? Bspw. scheint /c/c_programming nicht zur Verfügung zu stehen.

Wie funktioniert das? :)

@lut
1
edit-2
1M

deleted by creator

@lut
31M

Habs getestet.

Also das liegt daran, weil diesem Server nicht alle communities bekannt sind, bzw der server noch nicht mitbekommen hat, dass drüben so eine community erstellt worden ist.

Die Lösung ist, diesen Link manuell herzustellen. D.h. du suchst z.B. in den communities von lemmy.161.social nach https://lemmy.ml/c/c_programming und subscribst da dann. Dadurch wird der Link hergestelltl, weil lemmy.161.social explizit versucht nachzugucken ob es https://lemmy.ml/c/c_programming gibt und dann in die Datenbank eintraegt.

@lut
51M

Das Verhalten ist gleich wie z.B. auf Mastodon, das ja auch das ActivityPub Protokoll nutzt. Da ist das Verhalten standardmäßig auch so. D.h. wenn du einen neuen Server erstellst, sind Beiträge von Nutzer auch erstmal nicht sichtbar bis zum ersten Mal wo eine Person einen Beitrag dieser Person boostet und der Link explizit hergestellt wird.

D.h. die äquivalente Lösung in Mastodon ist, explizit nach der ActivityPub identität bzw dem Link zu einem Posting in Mastodon “zu suchen”, wo dann natürlich nur 1 Ergebnis da ist. Aber dann hat der Server den Link hergestellt und MEnsch kann das boosten bzw dem Account folgen.

Deswegen gibt es auch relays, wo mehrere Server in Mastodon sich zusammen schließen, um mehr Postings bzw mehr Nutzer den Servern bekannt zu machen.

@ljrk
creator
31M

Danke für die Info, sowas in die Richtung, also “Link on demand” habe ich mir gedacht – leider finde ich c/c_programming nicht in der Community-Suche von 161.social, es wird lediglich die c/programming gefunden.

Wenn ich in lemmur (android app) suche wird es ebenfalls nicht in der 161.social Instanz gefunden, sondern nur in der lemmy.ml Instanz. Hier kann ich dann aber nicht subscriben, da ich keinen lemmy.ml account habe.

Mache ich irgendwas falsch?

@ljrk
creator
21M

@lut@lemmy.161.social entweder das ist auf desktop anders oder der Link wurde gerade erstellt – jetzt sehe ich die Instanz und konnte subben. Ich gucke mal ob ich eine andere Community finde bei der ich das gleiche Problem habe und dann, wie/wo ich das beheben kann.

@lut
2
edit-2
1M

Koennte gut sein, dass lemmur noch nicht so weit ist oder dass das da anders gemacht werden muss.

Bin nicht ganz sichere, ob ich dich richtig verstehe. Funktioniert das folgende nur auf android nicht, oder auch auf dem desktop nicht?

bei mir war das so, auf dem desktop: als erstes hab ich nach c_programming gesucht und da wurde nix gefunden. Dann hab ich nach https://lemmy.ml/c/c_programming gesucht und dann wurde !c_programming@lemmy.ml gefunden. Und dann hab ich da drauf geklickt und konnte subscriben.

@ljrk
creator
21M

Ich hatte vorher Mobil-Browser & Lemmur probiert aber dich falsch verstanden – in der Tat, wenn ich nach der kompletten URI suche bzw. die Instanz angebe, dann wird das gefunden, ergibt letztlich Sinn!

Auf Lemmur geht das tatsächlich noch nicht und ich habe bisher keinen GitHub Issue gefunden, und deshalb einen erstellt: https://github.com/krawieck/lemmur/issues/221

Danke dir für die Hilfe, das hat alle meine Fragen geklärt!

@lut
21M

Ah, nach !mathhumor@lemmy.ml zu suchen scheint auch zu gehen. D.h. nur nach mathhumor zu suchen -> 0 resultate. wenn ich nach obiger Lemmy-Adresse suche, kommt ebenfalls 0 resultate, aber der ok-button dreht sich bzw laedt noch. nach ein paar minuten die seite neu laden und !mathhumor@lemmy.ml wird erfolgreich aufgeloest.

@lut
21M

achja, und: willkommen!

@ljrk
creator
31M

Danke – auf einen schönen Austausch :)

Sachen rund um die Platform, hosting, Regeln, …

  • 0 users online
  • 2 users / day
  • 3 users / week
  • 5 users / month
  • 11 users / 6 months
  • 39 subscribers
  • 12 Posts
  • 51 Comments
  • Modlog